Xcode 10 缺少 libstdc++ 库的处理

作者:暗夜星辰 发布于:2018-10-10 9:56 Wednesday 分类:IOS学习笔记

目前Xcode10 已经发布数日,我们也顺利的升级到Xcode10,
在通过Xcode 10 进行日常开发和打包编译时遇到了 library not found for -lstdc++.6.0.9 的错误。

错误的原因是 
苹果在 iOS 12.0 中去掉了这个库,用自家的 libc++ 来替代 libstdc++。性能更好,速度更快。推荐升级
收到影响的第三方...

阅读全文>>

标签: App xcode 发布 错误 libstdc++ iOS12

评论(0) 引用(0) 浏览(362)

关于iOS测试机个数上限的详细规则

作者:暗夜星辰 发布于:2016-5-16 21:07 Monday 分类:IOS学习笔记

前言

公司的iOS测试机快达到苹果规定的100个上限了,而因为the new iPad新出,我们需要新的quota来测试新iPad,所以就仔细研究了一下苹果关于100个测试设备上限的规则。在这里分享给大家。规则的详细内容主要来自 苹果的官网文档

规则

我总结出来的规则如下(附上原文以便对应):

  • 每一个开发者membership year,只能有100次增加设备的名额。如果你增加一个设备,之后又...

阅读全文>>

标签: IOS 测试 测试机 上限

评论(0) 引用(0) 浏览(1828)

证书错误:No matching provisioning profiles found

作者:暗夜星辰 发布于:2016-5-7 17:01 Saturday 分类:IOS学习笔记

在Xcode中当你在更新了你得证书而再重新编译你的程序,真机调试会出现“Your build settings specify a provisioning profile with the UUID‘XXX’, however, no such provisioning profile was found.  Xcode can resolve this issue by downlo...

阅读全文>>

标签: IOS xcode UUID 证书 苹果账号

评论(0) 引用(0) 浏览(1950)

iOS9.3 Could not find Developer Disk Image 真机调试错误解决办法

作者:暗夜星辰 发布于:2016-3-28 21:17 Monday 分类:IOS学习笔记


iOS系统目前升级9.3,真机测试的时候发现Xcode(7.2.1)报错:Could not find Developer Disk Image , 这是因为我们的Xcode7.2中还没有支持9.3的Disk Image。

解决办法:

1、下载该Disk Image,放到/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.plat...

阅读全文>>

标签: App IOS xcode 升级 真机调试

评论(0) 引用(0) 浏览(3035)

iOS开发证书变成“此证书的签发者无效”解决方法

作者:暗夜星辰 发布于:2016-3-26 18:31 Saturday 分类:IOS学习笔记

IOS开发证书全部变成无效,如下图
这里写图片描述

打包提示错误

解决方法:

阅读全文>>

标签: App IOS xcode IOS开发 mac iphone 证书

评论(0) 引用(0) 浏览(1847)

svn报错cleanup failed–previous operation has not finished; run cleanup if it was interrupted的解决办法

作者:暗夜星辰 发布于:2016-3-17 10:35 Thursday 分类:IOS学习笔记

今天在svn提交的时候它卡顿了一下,我以为已经提交完了,就按了一下,结果就再也恢复不了,也继续不了了...

报错 

cleanup failed–previous operation has not finished; run cleanup if it was interrupted

试过执行cleanup,结果也是失败,要更新先要cleanup,但是cleanup的失败信息又叫我clean...

阅读全文>>

标签: SVN mac 数据库 shell sqlite

评论(0) 引用(0) 浏览(2717)

记录一次CocoaPods安装

作者:暗夜星辰 发布于:2015-12-29 14:32 Tuesday 分类:IOS学习笔记

本来打算升级安装CocoaPods  

结果Ruby版本不够,升级引发不少问题,总结一下


首先是检查Ruby版本 

#ruby -v

最新要求 ruby version >= 2.0 结果我的才1.9.* 不合格 无法安装

那么就升级吧

 

在mac下管理ruby 我们使用rvm 不过我的rvm版本也低了

一起升级了

# checks out from repo
rvm upd...

阅读全文>>

标签: TPS mac CocoaPods Ruby rvm 升级

评论(0) 引用(0) 浏览(3986)

Xcode ITMS-90535 错误

作者:暗夜星辰 发布于:2015-11-20 16:22 Friday 分类:IOS学习笔记

如果提交审核遇到 ITMS-90535 错误,删除相关的Info.plist即可,一般是不小心打包进去的。

比如ShareSDK里附带的TencentOpenApi_IOS_Bundle.bundle/Info.plist 

点击查看原图

 

阅读全文>>

标签: IOS xcode 打包 审核

评论(0) 引用(0) 浏览(2862)

©2012-2014 woodbunny.com 木头♥兔子的小屋 sitemap